Our full technical support staff does not monitor this forum. If you need assistance from a member of our staff, please submit your question from the Ask a Question page.


Log in or register to post/reply in the forum.

Timestamp previous day


Makada Nov 1, 2019 12:04 AM

Hi,

I have set the option in the output file options to midnight is 2400.

But i still get my daily file with timestamp from today instead of yesterday.


Makada Nov 3, 2019 08:06 AM

Is it ok to set the datainterval like this to have the timestamp from yesterday?:

Datainterval (-1,1,Day,10)


Makada Nov 6, 2019 04:49 AM

I see the actual dat file with daily data is showing the timestamp ok.

Today is 6th november, the dat file is showing 2019-11-05 24:00:00.......etc.

So thats ok, but i dont onderstand why its showing a timestamp from today in rtmc pro graphs...


Makada Jan 3, 2020 12:14 PM

Im still strugling with this problem. 

Ive made some printscreens to make things clear.

As you can see ive set it up like which i think it should work, but it doesnt. 

In the rtmc pro table display you can see the timestamps , the newest from 3 january (today) , but should be from 2 january....

You can see ive set the output file options to Midnight is 2400.

And part of my crbasic code showing the datainterval set to 1 day.

What have is set up wrong or am i doing wrong?

Cheers.

https://imgshare.io/image/Hq6T5

https://imgshare.io/image/HqN1u

https://imgshare.io/image/HqrnX


JDavis Jan 3, 2020 01:23 PM

RTMC is using the local time format of your computer, and your computer reports midnight as 00:00 of the next day. That is the international standard way to display midnight.

The solution in RTMC Pro is to apply a -1 second time offset to your data. Use a time format that only shows the date, and no one will notice that midnight is now 23:59:59. You can make those changes in the properties of the table.


Makada Jan 3, 2020 01:29 PM

Ok thanks.

Maybe i can set my pc to show Midnight as 2400...?

Do you mean i have to make changes in the crbasic table or in the setup screen or in the rtmc time series chart properties?

I have a table with datainterval "day" and "month".

Cheers.


Makada Jan 3, 2020 02:03 PM

Do you mean like so?

DataInterval(86399,86400,Sec)

Thats daily data,  but how can i achieve that with monthly datatable?

Cheers.


Makada Jan 4, 2020 06:41 AM

Could this be a proper solution?

For daily table: DataInterval(-1,1,Day,10)

For monthly table: DataInterval(-1,1,Month,10)


Makada Jan 6, 2020 02:16 AM

...i think the - has to be removed from Tintoint...

I get skipped scans with -1.


JDavis Jan 6, 2020 08:36 AM

If the issue is just the display in RTMC, you do not need to change your datalogger program at all. In your RTMC project, you can apply a time offset in the tables.


Makada Jan 6, 2020 11:55 AM

Yes, ive tried that, but with a table display (In rtmc pro, insert new, trends, table display) where ive set the time offset to -1, it takes ages to set the desired custom range in the report range properties.  It sometimes freeze Loggernet and have to force Loggernet to quit and restart it.

Cheers.


Makada Jan 7, 2020 07:59 AM

Would it be an idea to have a time offset option in the report range function so it correspond with the time offset set in the table display?

Ive found this example but i dont know how to use it for a daily table...:

If Time_DayOfMonth = 1 AND IfTime(0,1,Day) Then

Call Table 1

Cheers.

Log in or register to post/reply in the forum.